Platform Service Disruption

Incident Report for HelloID

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 18:56 UTC

Update

We are continuing to investigate this issue.
Posted Jun 23, 2025 - 15:28 UTC

Investigating

We are currently experiencing issues with our platform services. As a result, domain validation and email validation may not function as expected. Other parts of the platform may also be affected.
Our team is actively investigating and working to resolve the issue. We will provide updates as soon as more information is available.
Thank you for your patience.
Posted Jun 23, 2025 - 14:50 UTC
This incident affected: HelloID West Europe (Provisioning) and HelloID West America (Provisioning).