Delegated forms and datasources can't be edited
Incident Report for HelloID
Resolved
This incident has been resolved.
Posted Oct 03, 2024 - 09:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2024 - 06:16 UTC
Identified
We are experiencing issues with admins that are not able to edit delegated forms or datasources.
The issue has been identified and we are working on a fix.
Posted Sep 10, 2024 - 07:14 UTC
This incident affected: HelloID West Europe (Service Automation), HelloID West America (Service Automation), and HelloID Training (Service Automation).