HelloID On-Premise agent – connection recovery issue

Incident Report for HelloID

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2026 - 10:21 UTC

Identified

We are currently experiencing an issue where the HelloID on-premise agent may have lost its connection and did not automatically recover.

You can resolve this by manually restarting the three HelloID services. For instructions, see: https://docs.helloid.com/en/agent/restart-an-agent.html

We are actively working on a permanent solution for this connectivity issue. Our apologies for the inconvenience.
Posted Feb 21, 2026 - 09:56 UTC
This incident affects: HelloID West Europe (Provisioning), HelloID West America (Provisioning), and HelloID Training (Provisioning).