Email delivery delay to @live.nl, @msn.com, @outlook.com and @hotmail.com

Incident Report for HelloID

Resolved

After investigation, it has been determined that the issue is not related to HelloID, nor to the mail provider used by HelloID.
Posted Feb 26, 2026 - 13:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2026 - 08:36 UTC

Investigating

We’re currently experiencing issues with email delivery to the domains @live.nl, @msn.com, @outlook.com and @hotmail.com due to a problem at our mail provider.

Emails that have already been sent are in a retry queue and will be delivered automatically once the issue has been resolved.

Our mail provider is aware of the problem and is actively investigating it. We will provide an update as soon as more information becomes available.
Posted Feb 24, 2026 - 09:06 UTC
This incident affected: HelloID West Europe (Provisioning, Service Automation, Access Management).