Occational error loading datasources
Incident Report for HelloID
Resolved
Some instances where unable to resolve certificates after the deployment of 2022.5. A restart of these instances was necessary to resolve this issue. We are looking in options to improve this section into the software to prevent this from happening.
Posted May 10, 2022 - 12:08 UTC
Investigating
Sometimes when a datasource is used in a form an error message pops up: "Something went wrong while retrieving data for a form element".
Refreshing the form seems to solve the issue.

We are investigating this issue.
Posted May 10, 2022 - 07:59 UTC
This incident affected: HelloID West Europe (Service Automation).