HelloID 2026.06 update postponed

Incident Report for HelloID

Resolved

The HelloID 2026.06 update has been released.

If you have any questions or issues please contact HelloID customer support via https://tools4ever-support.topdesk.net/
Posted Jun 10, 2026 - 19:04 UTC

Identified

The HelloID 2026.06 release is now scheduled for Wednesday, June 10 at 20:00 CEST.

A separate maintenance window will be announced for this release. The status and progress of the release will be communicated through this maintenance window.
Posted Jun 10, 2026 - 08:27 UTC

Investigating

During the HelloID release process, we identified an issue related to Access Management. As a result, we are required to postpone the 2026.06 release for WE until further notice.

This issue does not affect the current operation of the platform.
Posted Jun 08, 2026 - 14:46 UTC
This incident affected: HelloID West Europe (Provisioning, Service Automation, Access Management).