Unexpected behavior of delegated form tasks
Incident Report for HelloID
Resolved
The issue has been resolved but there are some client side effects still in play due to caching.

This cache will remain active for quite some time. The workaround is to use the delegated form edit screen (task editing) in another browers or a private/incognito browser session to circumvent this cache. This cache will remain active for a period of 180 minutes, three hours.



The backend services are using a shorter cache timeframe and have resolved the correct values. When you have any tasks resulting from delegated form submissions, that are in a pending state, can be restarted.

Go to the Activity overview screen on the Admin side of HelloID and go into the activity and then go to 'Form submission logging' and click on 'Retry' in the top right corner of the modal.
Posted May 16, 2022 - 11:33 UTC
Monitoring
There is a feature flag to see the new style of tasks in delegated forms.
This feature flag has been removed prematurely which caused all the delegated forms to use the old style of tasks.

We solved this issue by returning the feature flag and will keep monitoring the delegated forms.
Posted May 16, 2022 - 10:54 UTC
This incident affected: HelloID West Europe (Service Automation).